System Requirements

iMIS architecture is made up of a single database server, one or more application servers (appservers), and two types of clients (a Windows application and a web application), which run on typical workstations. These requirements apply across database servers, appservers, and workstations. Web clients only need to meet requirements for displays and browsers.

Note: You must install hotfix (A) after completing an initial install of 20.2, or an upgrade to 20.2. You can access this hotfix by going to ftp://ftp.advsol.com/download/Restricted/Hotfixes/20_2_1_GA/20.2.1(A)_SMR340168_and_SMR342275.zip. Contact ASI Technical Support for further assistance.

Note: This version supports upgrades from any version of iMIS, starting with 15.1.3. For best results with earlier versions of iMIS, complete the upgrade to 15.1.3 before proceeding.

Note: The installer removes any existing files for unsupported products, which includes e-CM, e-CM 5.1 publishing service, e-Series, and iBO for COM.

Minimum hardware (all)

  • 100/1000 Mbps network connection between database server host and all appservers and iMIS desktop clients.
  • 2 GHz Intel Pentium 4 or compatible processor (64-bit processors must support Intel 64 or AMD64 architectures).
  • 2 GB of RAM.
  • 3.2 GB of disk space for a full/custom install. 1.8 MB for Advanced Accounting Console install/upgrade (InstallShield might under-report disk space needed).
  • An additional 2 GB of disk space on the C: drive (for temp files). When upgrading, an additional amount of C: drive disk space on the database server that totals twice the size of your database.
  • Application Server: additional disk space for publishing and indexing your contact files for search (for example, 275K contacts=1GB, 2M contacts=7.56GB).
  • Display with 1024x768 (XVGA) minimum resolution.

Operating systems

  • Servers: Windows Server 2008 R2 SP1, 2012 and 2012 R2 (64-bit, Standard/Enterprise/Datacenter editions only)
  • Workstations: Windows Vista SP2, Windows 7 SP1, and Windows 8.0 and 8.1 (32-bit and 64-bit), installed as and set to run as Administrator, with non-Aero theme.

Databases

  • Microsoft SQL Server and Express Edition 2014
  • Microsoft SQL Server and Express Edition 2012 SP2
  • Microsoft SQL Server and Express Edition 2008 SP3 and 2008 R2 SP3 (32-bit and 64-bit)
  • Note: 2008 R2 is not backwards compatible.

Appservers

  • Microsoft .NET Framework 3.5 and 4.5 (ASP.NET)
  • SQL Server 2008/2012/2014 Management, Client, and Backward Compatibility Client Tools
  • Microsoft Internet Information Services (IIS) 7.5, 8.0, or 8.5
  • Java Runtime Environment (JRE) Version 7
  • Apache Lucene 4.1 Indexing and Search (included with install).

Systems running iMIS Advanced Accounting Console

  • Microsoft .NET Framework 3.5 and 4.5 (ASP.NET)
  • Microsoft Word 2007 SP3 and Word 2010 SP2 for Word integration
  • Microsoft Excel 2007 SP3, Excel 2010 SP2, and Excel 2013 SP1 for iMIS Analytics
  • Adobe Reader XI, installed on all servers and clients to print iMIS reports
  • (optional) ExpoCAD 7.4
  • Omnis 7 version 3.6.4 (included with install)

Browsers

  • Internet Explorer 8-11 (native) for RiSE
  • Internet Explorer 8 (compatibility mode) for all non-RiSE .NET web applications
  • Internet Explorer 9-11 for iMIS Advanced Accounting Console and remote Advanced Accounting Console
  • Firefox (most recent stable version, version 32 as of 6 Oct 2014) for RiSE, web views and remote Advanced Accounting Console
  • Chrome (most recent stable version, version 37 as of 6 Oct 2014) for RiSE and remote Advanced Accounting Console
  • Apple OS X and IOS 8.0: native default browser, for RiSE
  • Google Android 4.4: native default browser, for RiSE

Report writing

  • Reporting Services: SQL Server 2008 and 2008 R2 Business Intelligence Development Studio (BIDS); or SQL Server 2012 SQL Server Data Tools (SSDT).
  • Crystal Reports 9.0.

Additional components

Note: Optional products, such as Analytics, might have additional requirements. See the reference materials for these products to review any requirements or installation information.

Note: If you have a small implementation and can work within the size limitations, use Microsoft SQL Server Express Edition instead of Microsoft SQL Server.

Note: Any references to the iMIS public view are included as reference information for the configuration or maintenance of iMIS installations that already include an iMIS public view. You cannot install iMIS public view during an initial iMIS installation process.